[Debian-ni] Problemas luego de un rsync

Marcelo Gutierrez mmgc84 en gmail.com
Jue Dic 25 03:18:24 CET 2014


El 23 de diciembre de 2014, 12:22, Roberto José Blandino Cisneros <
rojoblandino en gmail.com> escribió:

> Luego de hacer un rsync todo mi sistema se va, creía que era por el madm,
> ya que mi rootfs está en el raid, por lo que levante un liveCD e intente
> sincronizar con rsync, el primero se hace sin ningún problema pero luego
> con el segundo ocurre lo siguiente:
>
> Hola Roberto, entiendo mas o menos tu problema, veo varias pasos que
deberias de seguir segun mi experiencia.

1. Primero que todo como esta definida tu tabla de particiones
2. Que sistema de archivos tienen tus particiones
3. Lei al suave el man de rsync, pero ya revisastes que tus opciones puedan
seguir a los enlaces simbolicos.

OTOH(On the Other Hand), estas quieriendo copiar una particion o un disco
completo, rsync puede hacerlo pero yo te recomendaria usar dd, ya que clona
particiones o discos completos.

Saludos cordiales


> # rsync -avHK --delete  root en 192.168.1.5:/var/lib/vz/private/123/
> /root/disk3/private/123/
> rsync: delete_file:
> unlink(lib64/live/mount/rootfs/filesystem.squashfs/usr/share/icons/HighContrast/32x32/status/software-update-available.png)
> failed: Read-only file system (30)^Crsync error: received SIGINT, SIGTERM,
> or SIGHUP (code 20) at rsync.c(549) [receiver=3.0.9]
> .....
>
> una vez que cancelo por que veo tantos errores como estrellas en el cielo,
> me doy cuenta que me quedo sin SO igual como sucedía con el SO anfitrión,
> por lo tanto dudo que sea meramente del arreglo con el mdadm que tengo y
> puede que sea un problema de ajuste quizás en la velocidad de
> sincronziación entre los discos del arreglo y esto causa quizás un crash.
>
> el problema es que luego de que ocurre el crash el SO queda inutilizable:
>
> -bash: /usr/bin/rsync: No such file or directory
>
> Haga lo que haga no importa que haga:
>
> root en debian:~# ls
> -bash: /bin/ls: No such file or directory
>
> Me deja en la sesión activa no me saca pero no tengo rootfs ni sistema.
>
> Así que debo de reiniciar y reintentar pero desconozco que problema es el
> que causa este problema, solo lo relaciono con el RAID pero no veo por que
> deba de dejarme sin SO.
>
> Y si accedo localmente resulta que de igual forma no hay rootfs, por lo
> que no puede hacer más que reiniciar.
>
> ¿Alguna idea de lo que pueda ser?
>
> Siempre sucede cada vez que sincronizo al servidor, no así cuando leo
> hacia otro.
> --
> ================
>
>
> _______________________________________________
> Debian-ni mailing list
> Debian-ni en debian.org.ni
> http://mail.debian.org.ni/mailman/listinfo/debian-ni_debian.org.ni
>
> Saludos y feliz navidad


-- 
Marcelo Gutierrez
Team POSOL http://podcast.softwarelibre.org.ni
Linux User: 448194
Ubuntu User: 26821
http://mmgc84.taygon.com
------------ próxima parte ------------
Se ha borrado un adjunto en formato HTML...
URL: <http://mail.debian.org.ni/pipermail/debian-ni_debian.org.ni/attachments/20141224/d2287099/attachment-0005.html>


Más información sobre la lista de distribución Debian-ni